Skip to main content

Changes to OS requirements for PowerApps mobile app

To provide you with the best experience, PowerApps is changing to support iOS’s two most recent versions and Android’s four most recent versions. This will be effective starting Decemeber 1, 2019. For example, going forward PowerApps will be supported for iOS 13 and iOS 12. When iOS 14 is released, PowerApps will be supported for iOS 14 and iOS 13. Similarly, PowerApps will be supported for Android OS versions 10, 9, 8 and 7. Moving forward, as new versions of OS are made generally available, Microsoft will drop support for the versions using the policy described above and only newer versions will be supported.

What if I don’t update OS to a supported version?

If you’re on an unsupported version of iOS or android, your PowerApps app will still work but you would no longer receive any updates including security updates. For example, if you’re on iOS 12, but later you don’t update your OS to a supported version when iOS 12 is no longer supported, you won’t receive any updates of any kind. As new major versions of iOS and android are released and older versions become unsupported, we highly recommend you continue to update your OS to a supported version in order to receive mainstream support such as security updates as well as new features.

Questions/Concerns? Let us know in the comments below. Tag @Kavishi_MSFT in the PowerApps community forums or @kavishiag on Twitter.